f

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

  1. An integer K(1<=K<=2000) representing the total number of people;
  2. K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
  3. (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
    Output
    For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
    Sample Input
    2
    2
    20 25
    40
    1
    8
    Sample Output
    08:00:40 am
    08:00:08 am
    这个题是一个dp的题,他的题意是真的难懂啊,这个题的题意是给你总的人数还有一个人买票的时间还有两个人买票的时间,然后让你求出这些人买完票一共要花多长的时间。
    这个题的样例我看了一天才看懂的,真的是服了我的理解力太差了。我失踪数着这个样例是不是少了一行,最后才发现这个样例原来是最后那个样例只有一个人,没有可以拼票的。
    然后说说这个题的思路吧,对其中一个人分析,这个人可以可以选择单独买也可以选择和前面那个人拼一张票,这里公式就出来了很简单的一个 dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);
    这个人是am八点开始的,输出走时的时间,可能为am可能为pm。
    这里还有几个小技巧,就是如果两个数要输出其中一个数如果只有个位数的话就要十位数是0那这个可以用**<<setw(2)<<setfill(‘0’)**来达到目的。
#include <iostream>
#include <iomanip>
using namespace std;
int a[3000],b[3000],dp[3000];
int main()
{
    int n,t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i<n;i++)
            cin>>b[i];
        dp[1]=a[1];
        for(int i=2;i<=n;i++)
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);
        int h=dp[n]/3600+8;
        int m=dp[n]/60%60;
        int s=dp[n]%60;
        if(h<12)
            cout<<setw(2)<<setfill('0')<<h<<":"<<setw(2)<<setfill('0')<<m<<":"<<setw(2)<<setfill('0')<<s<<" am"<<endl;
        else cout<<setw(2)<<setfill('0')<<h<<":"<<setw(2)<<setfill('0')<<m<<":"<<setw(2)<<setfill('0')<<s<<" pm"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值