HDU 5761_2016 Multi-University Training Contest 3

Rower Bo

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 659 Accepted Submission(s): 210
Special Judge

Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can’t arrive origin anyway,print”Infinity”(without quotation marks).

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0≤a≤100, 0≤v1,v2,≤100, a,v1,v2 are integers

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 10−4, your solution will be accepted.

Sample Input
2 3 3
2 4 3

Sample Output
Infinity
1.1428571429

Source
2016 Multi-University Training Contest 3

真的不说什么了,比赛时想到了微分,结果运动的情况想复杂了。……

其实就是v1始终指向(0,0)点,之后 设船到原点的距离为r,那么 r对t积分可以得到v2*cos@
(@为v1与原点连接之后与X轴的夹角) 接着说 (v1-v2*cos@)对时间T积分,上限T,下限0

沿x轴上下限均是0,v1*cous@-v2 对T积分,上限T,下限0。之后把第二个式子里的积分用等式换为以v1和v2的形式表达。那么 我们就可以得到结果

#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int a,v1,v2;
    while(~scanf("%d %d %d",&a,&v1,&v2))
    {
        if(a==0)
        {
            printf("0\n");
            continue;
        }
        else{
            if(v1<=v2)
            {
                printf("Infinity\n");
                continue;
            }
            else
            {
                double T=(a*v1*1.0)/(1.0*(v1*v1-v2*v2));
                printf("%lf\n",T);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值