poj 1840

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 14115 Accepted: 6940

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

这道题 不用能直接暴力 如果暴力5个for循环的话 是10的5次方  可以将原式变形  -(a1x13+ a2x23)= a3x33+ a4x43+ a5x5  这样时间复杂度是10的2次方+ 10的3次方 .另外交上又是 MLE , 又是TLE的,要注意的是 这道题我交的G++ 用scanf不会超时 用的cin才过的 另外 MLE的原因是数组过大  得用short定义 还有 直接计算某些式子比用函数快 

///为什么会加25000000 <原因转自 ζёСяêτ - 小優YoU >为了使得 搜索sum是否出现 的操作为o(1),我们把sum作为下标,那么hash数组的上界就取决于a1 a2 x1 x2的组合,四个量的极端值均为50
因此上界为 50*50^3+50*50^3=12500000,由于sum也可能为负数,因此我们对hash[]的上界进行扩展,扩展到25000000,当sum<0时,我们令sum+=25000000存储到hash[]
由于数组很大,必须使用全局定义
 
同时由于数组很大,用int定义必然会MLE,因此要用char或者short定义数组,推荐short<转自ζёСяêτ - 小優YoU>

看代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
short has[25000001];
int main(void)
{
    int  sum1,a1,a2,a3,a4,a5;
    while(cin>>a1>>a2>>a3>>a4>>a5)
    {
        sum1=0;
        memset(has,0,sizeof(has));
        for(int t1=-50; t1<=50; t1++)
        {
            if(t1==0)
                continue;
            for(int t2=-50; t2<=50; t2++)
            {
                if(t2==0)
                    continue;
                int sum=(-1)*(a1*t1*t1*t1+a2*t2*t2*t2);
                if(sum<0)
                    sum+=25000000;
                has[sum]++;

            }
        }
        for(int t3=-50; t3<=50; t3++)
        {
            if(t3==0)
                continue;
            for(int t4=-50; t4<=50; t4++)
            {
                if(t4==0)
                    continue;
                for(int t5=-50; t5<=50; t5++)
                {
                    if(t5==0)
                        continue;
                    int sum=a3*t3*t3*t3+a4*t4*t4*t4+a5*t5*t5*t5;
                    if(sum<0)
                        sum+=25000000;
                    if(has[sum]!=0)
                    {
                        sum1+=has[sum];
                    }
                }

            }
        }
        cout<<sum1<<endl;
    }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值