poj-2442Sequence

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4



#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int a[200][2100],b[2100];///a数组存输入的数据  可以认为缓存数据 让优先队列的数据存进b来进行相关比较 以便于再有再小的数值存进优先队列
int main()
{
    int n,m,t,i,j,k;
    scanf("%d",&t);
    while(t--)
    {
        priority_queue<int>q;///优先队列存的是当前m个 最小和
        scanf("%d %d",&n,&m);
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(i=0;i<m;i++)
        {
            q.push(a[0][i]);
        }
        for(i=1;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                b[j]=q.top();
                q.pop();
            }
            for(j=0;j<m;j++)
            {
                for(k=m-1;k>=0;k--)
                {
                    if(j==0)
                        q.push(a[i][j]+b[k]);
                    else
                    {
                        if(a[i][j]+b[k]<q.top())
                        {
                            q.pop();
                            q.push(a[i][j]+b[k]);
                        }
                        else
                            break;///已经排好序<从小到大> 如果a[i][j]+b[k]>=q.top() 后面的就没有必要比了
                    }
                }
            }
        }
        for(i=0;i<m;i++)///排序虽然是从小到大 但是出队时是从队尾出队列 所以下面的for循环i是从m-1开始
        {
            b[i]=q.top();
            q.pop();
        }
        for(i=m-1;i>=0;i--)
        {
            i==m-1?printf("%d",b[i]):printf(" %d",b[i]);
        }
       printf("\n");
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值