Sequence
Description
Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input 1 2 3 1 2 3 2 2 3 Sample Output 3 3 4 Source
POJ Monthly,Guang Lin
|
题意:
给你m(0<m<=100)个序列包含n(0<n<=2000)个正整数。现在每个序列选择一个数并组成一个新的序列,很明显有n^m种序列。现在我们需要计算出这n^m种序列每种序列的数列之和,输出前n个最小的数列之和。
思路:
优先队列,a数组存和,b存该组数据,
运用优先队列,我们可以维持第一个序列到第二个序列前n个最小的数列之和,之后递推到第n个序列。
a[0]+b[0]<=a[0]+b[1]......<=a[0]+b[n]
a[1]+b[0]<=a[1]+b[1]......<=a[1]+b[n]
......
a[2]+b[0]<=a[2]+b[1]......<=a[2]+b[n]
#include <iostream>
#include <vector>
#include <queue>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int T;
cin>>T;
while(T--)
{
int n, m;
cin>>n>>m;
priority_queue<int,vector<int>,less<int> > q;
int *a = new int[m];
int *b = new int[m];
for( int i = 0;i < m;i++ )
cin>>a[i];
sort(a,a+m);
for( int i = 1;i < n;i++ )
{
for( int j = 0;j < m;j++ )
{
cin>>b[j];
q.push(a[0]+b[j]);
}
sort(b,b+m);
for( int j = 1;j < m;j++ )
{
int flag = 0; //标识变量
for( int k = 0;k < m;k++ )
{
if( a[j]+b[k]<q.top() ) //当和小于顶部元素才进行更新
{
q.pop();
q.push(a[j]+b[k]);
flag = 1;
}
else
break;
}
if( !flag )
break;
}
for( int j = 0;j < m;j++ ) //更新存和数组
{
a[m-j-1] = q.top();
q.pop();
}
}
for( int j = 0;j < m;j++ )
{
if(!j)
cout<<a[j];
else
cout<<" "<<a[j];
}
cout<<endl;
}
return 0;
}