hdu 1518 Square dfs深搜算法

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16313    Accepted Submission(s): 5152


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source

dfs函数中搜索的for循环中的剪枝是关键

//hdu1016
//#include"stdafx.h"
#include<iostream>
#include<algorithm>
using namespace std;
#define size 30
int map[size];
bool visit[size];
bool flag = false;
int n, edgeLength;
//index:搜索的下标 edgeCount:已经拼成的边的数目 preLength:已经拼成的长度
void dfs(int index,int edgeCount,int preLength) {
	if (flag)
		return;
	if (edgeCount == 4) {
		flag = true;
		return;
	}
	//如果已经拼成的长度等于该正方形的边长 便你了下标从0开始
	if (preLength == edgeLength) {
		dfs(0, edgeCount + 1, 0);
		if (flag)
			return;
	}
	//for循环中的i=index是关键 减少遍历的次数 剪枝
	for (int i = index; i < n; i++) {	
		if (visit[i])
			continue;
		int lengthNow = preLength + map[i];
		if (lengthNow > edgeLength)
			continue;
		visit[i] = true;
		dfs(i + 1, edgeCount, lengthNow);
		visit[i] = false;
		if (flag)
			return;
	}
}

int main() {
	int cases;
	cin >> cases;
	while (cases--) {
		int sum = 0;
		cin >> n;
		for (int i = 0; i < n; i++) {
			cin >> map[i];
			sum += map[i];
		}
		if (sum % 4 != 0) {
			goto No;
		}
		edgeLength = sum / 4;
		for (int i = 0; i < n; i++) {
			if (map[i] > edgeLength)
				goto No;
		}
		sort(map, map + n);
		flag = false;
		memset(visit, false, sizeof(visit));
		dfs(0,0,0);
		if (flag)
			cout << "yes" << endl;
		else
			No:cout << "no" << endl;
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值