hdu 1711 Number Sequence kmp模式匹配

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30458    Accepted Submission(s): 12830


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source

#include<stdio.h>
#include<algorithm>
using namespace std;
#define  size 10010
int a[1000010], b[size];
int nextval[size];
int n, m;

void getNextval(int *T) {
    int k = -1;
    int j = 0;
    nextval[j] = k;
    while (j  < m) {
        if ((k == -1) || (T[j] == T[k])) {
            ++k;
            ++j;
            nextval[j] = k;
        }
        else {
            k = nextval[k];
        }
    }
}
//S为主串  从主串pos位置开始匹配
int index_KMP(int *S, int *T, int pos) {
    int i;
    int j;
    i = pos;
    j = 0;
    while ((i < n) && (j < m)) {
        /* j = -1 表示next[0], 说明失配处在模式串T的第0个字符。所以这里特殊处理,然后令i+1和j+1。*/
        if ((j == -1) || S[i] == T[j]) {
            i++;
            j++;
        }
        else {
            j = nextval[j];
        }
    }
    //找到
    if (m == j)
        return i - m;
    else
        return  -2;
}

int main() {
    int test;
    scanf("%d", &test);
    while (test--) {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++) {
            scanf("%d",&a[i]);
        }
        for (int i = 0; i < m; i++) {
            scanf("%d",&b[i]);
        }
        getNextval(b);
        int k = index_KMP(a, b, 0) + 1;
        printf("%d\n", k);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值