HRBUST 1012 Catch That Cow (BFS)

Catch That Cow
Time Limit: 2000 MSMemory Limit: 65536 K
Total Submit: 1914(545 users)Total Accepted: 800(504 users)Rating: Special Judge: No
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

For each test case :

Line 1: Two space-separated integers: N and K

Process to the end of file.

Output

For each test case :

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17
100 100
Sample Output
4
0


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int m,n;
int vis[200001];
int xx(int a)
{
    queue<int>k;
    k.push(a);
    while(!k.empty())
    {
        vis[a]=1;
        int a1=k.front();
        k.pop();
        if(a1==n)
        {
            return vis[n]-1;
        }
        for(int i=0; i<3; i++)
        {
            int a2;
            if(i==0)
            {
                a2=a1+1;
            }
            if(i==1)
            {
                a2=a1-1;
            }
            if(i==2)
            {
                a2=a1*2;
            }
            if(!vis[a2]&&a2>=0&&a2<100001)
            {
                vis[a2]=vis[a1]+1;
                k.push(a2);
            }
        }
    }
}
int main()
{

    while(scanf("%d%d",&m,&n)==2)
    {
        memset(vis,0,sizeof(vis));
        printf("%d\n",xx(m));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值