HDU - 6198 number number number(规律+矩阵快速幂)

number number number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 274    Accepted Submission(s): 174


Problem Description
We define a sequence  F :

  F0=0,F1=1 ;
  Fn=Fn1+Fn2 (n2) .

Give you an integer  k , if a positive number  n  can be expressed by
n=Fa1+Fa2+...+Fak  where  0a1a2ak , this positive number is  mjfgood . Otherwise, this positive number is  mjfbad .
Now, give you an integer  k , you task is to find the minimal positive  mjfbad  number.
The answer may be too large. Please print the answer modulo 998244353.
 

Input
There are about 500 test cases, end up with EOF.
Each test case includes an integer  k  which is described above. ( 1k109 )
 

Output
For each case, output the minimal  mjfbad  number mod 998244353.
 

Sample Input
  
  
1
 

Sample Output
  
  
4
 

Source
 

Recommend
liuyiding
 

Statistic |  Submit |  Discuss |  Note

题意:输入一个 k ,输出最小的不能由 k 个斐波那契数相加得到的正整数 n;

这题打表找规律,k = 1时 n = 4, k = 2时 n = 12,k = 3时 n = 33 ……规律即斐波那契数列的第 4+2*(k-1)项-1,最后用矩阵快速幂加速计算即可

#include <bits/stdc++.h>
using namespace std;

const long long N = 2, Mod = 998244353;
long long m, n;
struct xx{
    long long a[N][N];
} ori,res;

xx mul(xx x,xx y){
    xx temp;
    memset(temp.a, 0, sizeof(temp.a));
    for(int i = 0; i < N; i++){
        for(int j = 0; j < N; j++){
            for(int k = 0; k < N; k++){
                temp.a[i][j] += x.a[i][k]*y.a[k][j];
                temp.a[i][j] %= Mod;
            }
        }
    }
    return temp;
}

void init(){
    ori.a[0][0] = 1, ori.a[0][1] = 1;
    ori.a[1][0] = 1, ori.a[1][1] = 0;
    res.a[0][0] = 1, res.a[0][1] = 0;
    res.a[1][0] = 0, res.a[1][1] = 1;
}

long long calc(long long k){
    while(k){
        if(k & 1) res = mul(res, ori);
        ori = mul(ori, ori);
        k >>= 1;
    }
    return res.a[0][0];
}

int main(){
    while(scanf("%lld", &m) == 1){
        init();
        n = 4+(m-1)*2;
        printf("%lld\n", calc(n)-1);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值