HDU6198(矩阵快速幂)

number number number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 592    Accepted Submission(s): 374


Problem Description
We define a sequence  F :

  F0=0,F1=1 ;
  Fn=Fn1+Fn2 (n2) .

Give you an integer  k , if a positive number  n  can be expressed by
n=Fa1+Fa2+...+Fak  where  0a1a2ak , this positive number is  mjfgood . Otherwise, this positive number is  mjfbad .
Now, give you an integer  k , you task is to find the minimal positive  mjfbad  number.
The answer may be too large. Please print the answer modulo 998244353.
 

Input
There are about 500 test cases, end up with EOF.
Each test case includes an integer  k  which is described above. ( 1k109 )
 

Output
For each case, output the minimal  mjfbad  number mod 998244353.
 

Sample Input
  
  
1
 

Sample Output
  
  
4
 

Source
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string.h>
using namespace std;
typedef long long ll;
const int MOD=998244353;
struct matrix{
	ll a[2][2];
	matrix(ll num=0)
	{
		for(int i=0;i<2;i++)
			for(int j=0;j<2;j++)
			{
				a[i][j]=i==j?num:0;
			 } 
	} 
	matrix operator *(matrix b){
		matrix c;
		for(int i=0;i<2;i++)
			for(int j=0;j<2;j++)
				for(int k=0;k<2;k++)
				{
					c.a[i][j]=(c.a[i][j]+a[i][k]*b.a[k][j])%MOD;
				}
			return c;
	}
}E;
ll matrixQuickPow(matrix a,int n)
{
	matrix res(1);
	for(;n;n>>=1,a=a*a) if(n&1) res=res*a;
	return res.a[0][0];
}
ll work(ll n)
{
	n=n*2+2;
	E.a[0][0]=1;E.a[0][1]=1;
	E.a[1][0]=1;E.a[1][1]=0;
	return (matrixQuickPow(E,n)+MOD-1)%MOD; 
}
int main()
{
	for(ll n;~scanf("%lld",&n);printf("%lld\n",work(n)));
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值