HDU - 2586 How far away ?(LCA裸题)

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10580    Accepted Submission(s): 3851

 

Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

 

 

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

 

 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

 

 

Sample Input

 

2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1

 

 

Sample Output

 

10 25 100 100

 

题意:给出一棵树,问树上两点距离

 

#include <bits/stdc++.h>
using namespace std;

const int N = 4e4 + 10;
int t, n, m;
int tot;
struct xx{
    int to, val, nex;
} a[N<<1];
int dep[N], dis[N];
int fa[N][20], head[N];

void Init(){
    tot = 0;
    memset(a, 0, sizeof a);
    memset(dis, 0, sizeof dis);
    memset(dep, 0, sizeof dep);
    memset(fa, 0, sizeof fa);
    memset(head, -1, sizeof head);
}

void Add(int u, int v, int w){
    a[++tot].to = v, a[tot].nex = head[u];
    a[tot].val = w, head[u] = tot;
}

void dfs(int p, int f, int step, int deep){
    dis[p] = step, dep[p] = deep;
    fa[p][0] = f;
    for(int i = 1; i <= log2(dep[p]); i++){
        fa[p][i] = fa[fa[p][i-1]][i-1];
    }
    for(int i = head[p]; i != -1; i = a[i].nex){
        if(a[i].to != f){
            dfs(a[i].to, p, step+a[i].val, deep+1);
        }
    }
}

int Lca(int u, int v){
    if(dep[u] < dep[v]) swap(u, v);
    for(int i = 20; i >= 0; i--){
        if(dep[u] == dep[v]) break;
        if(dep[fa[u][i]] < dep[v]) continue;
        u = fa[u][i];
    }
    if(u == v) return u;
    for(int i = log2(dep[u]); i >= 0; i--){
        if(fa[u][i] == fa[v][i]) continue;
        u = fa[u][i], v = fa[v][i];
    }
    return fa[u][0];
}

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &n, &m);
        Init();
        int x, y, z;
        for(int i = 1; i < n; i++){
            scanf("%d%d%d", &x, &y, &z);
            Add(x, y, z); Add(y, x, z);
        }
        dfs(1, 0, 0, 0);
        while(m--){
            scanf("%d%d", &x, &y);
            printf("%d\n", dis[x]+dis[y]-2*dis[Lca(x, y)]);
        }
    }
}
#include <stdio.h>    ///kuangbin
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
/*
 * POJ 1330
 * LCA 在线算法
 */
const int MAXN = 10010;
const int DEG = 20;

struct Edge
{
    int to,next;
}edge[MAXN*2];
int head[MAXN],tot;
void addedge(int u,int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}
void init()
{
    tot = 0;
    memset(head,-1,sizeof(head));
}
int fa[MAXN][DEG];//fa[i][j]表示结点i的第2^j个祖先
int deg[MAXN];//深度数组

void BFS(int root)
{
    queue<int>que;
    deg[root] = 0;
    fa[root][0] = root;
    que.push(root);
    while(!que.empty())
    {
        int tmp = que.front();
        que.pop();
        for(int i = 1;i < DEG;i++)
            fa[tmp][i] = fa[fa[tmp][i-1]][i-1];
        for(int i = head[tmp]; i != -1;i = edge[i].next)
        {
            int v = edge[i].to;
            if(v == fa[tmp][0])continue;
            deg[v] = deg[tmp] + 1;
            fa[v][0] = tmp;
            que.push(v);
        }

    }
}
int LCA(int u,int v)
{
    if(deg[u] > deg[v])swap(u,v);
    int hu = deg[u], hv = deg[v];
    int tu = u, tv = v;
    for(int det = hv-hu, i = 0; det ;det>>=1, i++)
        if(det&1)
            tv = fa[tv][i];
    if(tu == tv)return tu;
    for(int i = DEG-1; i >= 0; i--)
    {
        if(fa[tu][i] == fa[tv][i])
            continue;
        tu = fa[tu][i];
        tv = fa[tv][i];
    }
    return fa[tu][0];
}
bool flag[MAXN];
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    int n,m;
    int u,v;
    while(scanf("%d", &n) == 1)
    {
        init();
        memset(flag,false,sizeof(flag));
        for(int i = 1;i < n;i++)
        {
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
            flag[v] = true;
        }
        int root;
        for(int i = 1;i <= n;i++)
            if(!flag[i])
            {
                root = i;
                break;
            }
        BFS(root);
        scanf("%d", &m);
        while(m--){
            scanf("%d%d",&u,&v);
            printf("%d\n",LCA(u,v));
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值