HDU1016--DFS Prime Ring Problem【题解】

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66404    Accepted Submission(s): 28462


 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6 
1 6 5 2 3 4
 
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Click here!

题目大意:

给出一个n,把1~n排列成一个环,要求相邻俩个之和必须是素数(第一个和最后一个之和也要为素数)

深搜简单题  下放代码

#include<bits/stdc++.h>
using namespace std;
int prime[20]={2,3,5,7,11,13,17,19,23,29,31,37};
int ans[30];
bool flag[30];
bool jud=false;
int  n,num = 1;
void dfs(int cnt)
{
    if(cnt==n)
    {
        for(int i = 0; i <12; i++)
            {
                if((ans[1]+ans[cnt])==prime[i])
                    {jud = true; break;}
            }
        if(jud)
        {
            jud = false;
        for(int i = 1; i < n ; i++){
            cout<<ans[i]<<" ";
        }
        cout<<ans[n];
        cout<<endl;
        }
        return ;

    }

    for(int i =2 ; i <= n ; i++){
        for(int j = 0 ; j < 12; j++){
            if(!flag[i]&&(i+ans[cnt])==prime[j]){
                flag[i] = 1;
                ans[cnt+1]=i;
                dfs(cnt+1);
                flag[i] = 0;
            }

        }
    }
}
int main()
{
    while(cin>>n)
    {
        memset(flag,0,30);
        memset(ans,0,30);
        flag[1]=1;
        ans[1] =1;
        cout<<"Case "<<num++<<":"<<endl;
        jud = false;
        dfs(1);
        cout<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值