HDU - 1016 Prime Ring Problem(解题报告 素数环——dfs基础题)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number
1, 2, …, n into each circle separately, and the sum of numbers in two
adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Inputn
(0 < n < 20).

Output
The output format is shown as sample below.
Each row represents a series of circle numbers in the ring beginning
from 1 clockwisely and anticlockwisely. The order of numbers must
satisfy the above requirements. Print solutions in lexicographical
order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:

将自然数1,2,…,n分别放入一个圆中,相邻两个圆中的数之和应为素数。第一个圆的数目应始终为1。

思路:

先打印出一张素数表,不用存储素数的,是素数的标记为1,不是标记为0.然后再进行深度优先搜索,出口相邻的二个数相加为素数。老老实实地敲深搜就OK了。

AC代码

#include<stdio.h>
#include<string.h>
void dfs(int cur);
int prime(int x);

int n,a[20],b[41],c[20];

int main()
{
     int i;
     for(i=2;i<=40;i++)
        b[i]=prime(i);//打表
     int k=1;  
     while(scanf("%d",&n)!=EOF)
     {
        a[0]=1;
        printf("Case %d:\n",k++);
        if(n%2==0)
        {
        	dfs(1);开始深搜
		}
       printf("\n");
     }  
	 return 0;    
}

int prime(int x)
{
    int i;
    for(i=2;i*i<=x;i++)
       if(x%i==0)
       {
         return 0;
         break;
        }
    return 1;
} 
     
void dfs(int cur)
{
	int i;
    if(cur==n&&b[a[0]+a[n-1]])
    {
        for(i=0;i<n-1;i++)
           printf("%d ",a[i]);
        printf("%d\n",a[n-1]);
    }
    else
      for(i=2;i<=n;i++)
         if(!c[i]&&b[i+a[cur-1]])
         {
                a[cur]=i;
                c[i]=1;
                dfs(cur+1);
                c[i]=0;
        }
 
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

沐雨风栉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值