PAT甲级 1031 Hello World for U(20) (字符串+模拟)

该博客主要介绍了PAT甲级考试中的一道题目,要求将输入的字符串按照特定的'U'形状进行输出。文章提供了样例输入、输出及题意解析,并给出了实现代码,旨在帮助读者理解并解决问题。
摘要由CSDN通过智能技术生成

题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n_{1}​ characters, then left to right along the bottom line with n_{2} characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n_{1}​=n_{3}​=max { k | k≤n_{2}​ for all 3≤n2​≤N } with n_{1}+n_{2}​+n_{3}​−2=N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

样例输入 

helloworld!

样例输出 

h      !
e     d
l       l
lowor

题意理解

给你一个字符串,最后输出成一个u形的结果,那么我们模拟即可

代码 

#include<bits/stdc++.h> 
using namespace std;
typedef long long LL;
typedef unsigned long long ULL ;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
#define fx first
#define fy second
#define io ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
const int INF=0x3f3f3f3f;
const double DINF=0x7f7f7f7f;
const LL  LINF=1e18;
const int N=1e3+10;
const int M=2e2+10;
const int MOD=1e9+7;
char ss[N];
char ans[N][N];
int main(){
    scanf("%s",ss);
    int len=strlen(ss);
    int n1=(len+2)/3;
    int n2=len-2*n1+2;
    
    for(int i=0;i<n1-1;i++){
        cout<<ss[i];
        for(int j=0;j<n2-2;j++)cout<<" ";
        
        cout<<ss[len-i-1]<<"\n";
    }
    
    for(int i=0;i<n2;i++){
        cout<<ss[n1+i-1];
    }
    puts("");
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值