PAT 甲级 1031 Hello World for U (20分)

题目

1031 Hello World for U (20分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n 1 n_1 n1= n 3 n_3 n3=max { k | k≤ n 2 n_2 n2 for all 3≤ n 2 n_2 n2≤N } with n 1 + n 2 + n 3 − 2 = N n_1+n_2+n_3−2=N n1+n2+n32=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意

给出一个字符串,按照U字型输出它,

思路

根据题目中的要求求出 行数 n 1 n_1 n1和列数 n 2 n_2 n2,然后输出即可

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int n1, n2, N, med;
    string s;
    cin>>s;
    N = s.size();
    for(n1 = N; n1 > 0; n1--)
        if(N+2-2*n1 >= n1){
            n2 = N+2-2*n1;
            break;
        }
    for(int i=0; i<n1-1; i++)
        printf("%c%*c%c\n",s[i], n2-2, ' ', s[N-1-i]);
    for(int i = n1-1; i<n1+n2-1; i++)
        printf("%c",s[i]);
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值