PAT甲级 1046 Shortest Distance(20) (前缀和)

题目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^{5}]), followed by N integer distances D_{1}​ D_{2}​ ⋯ D_{N}​, where D_{i} is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^{4}), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^{7}.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入 

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出 

3
10
7

题意理解

给你n条边 m个询问 是一个环形的高速公路 让你求出 两点之间的最短距离 也就是你 可以从这头顺时针跑 或者 逆时针跑 问最短距离是多少

n个点 n条边 刚刚好是一个环 

先来理解一下样例

1->2 距离是1 

2->3 距离是2

3->4 距离是4

4->5 距离是14

5->1 距离是9

那么 1 3的询问最短距离就是3 顺时针的方向

2 5的询问就是10 逆时针方向

4 1的询问就是7 顺时针方向

那么我们采用前缀和的思想

把整个距离都记录下来 然后通过预处理的前缀和查询两点之间的距离

sum是跑个循环的距离 两点之间的距离用前缀和记录 反方向的用整个的距离减去前缀和的记录的顺时针距离 两者取一个 Min 就是我们最后的最短距离

代码 

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N=2e5+10;
LL a[N],b[N];
LL sum=0,x;
int n,m;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%lld",&x);
        a[i]=x;
        b[i]=b[i-1]+a[i];
        sum+=x;
    }
    scanf("%d",&m);
    while(m--){
        int a1,b1;
        scanf("%d%d",&a1,&b1);
        LL nu=abs(b[b1-1]-b[a1-1]);
        printf("%lld\n",min(nu,sum-nu ) );
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值