PAT甲级 1050 String Subtraction(20) (字符串)

题目

Given two strings S1​ and S2​, S=S1​−S2​ is defined to be the remaining string after taking all the characters in S2​ from S1​. Your task is simply to calculate S1​−S2​ for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S_{1}​ and S_{2}, respectively. The string lengths of both strings are no more than 10^{4}. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S_{1} -S_{2},​ in one line. 

样例输入 

They are students.
aeiou

样例输出 

Thy r stdnts.

题意理解

给你两个字符串

如果字符串2里面出现过的字符 那么在字符串1中过滤掉它

最后输出处理好的字符串1

代码 

#include<bits/stdc++.h>
using namespace std;

string s1,s2;
unordered_map<char,int>ma;
int main(){
    getline(cin,s1);
    getline(cin,s2);
    for(int i=0;i<s2.size();i++){
        ma[s2[i]]++;
    }
    for(int i=0;i<s1.size();i++){
        if(ma.count(s1[i]))continue;
        cout<<s1[i];
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值