(PAT)1050 String Subtraction(哈希,字符串读取)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:Thy r stdnts.

这里字符串会读取空格,所以用cin>>string的话会出错,所以最好用getline()来读取

读取方式:

string a, b;
getline(cin, a);
getline(cin, b);

如果要把char的ascii码作为索引传入的话,直接在哈希表数组索引中传入char就行了,系统会发生隐式转换

查找的时候根据输入字符串的ascii码去找就行了,没有必要进行遍历操作

代码:

#include <iostream>
#include <string>
using namespace std;
const int maxn =10001;
bool hashTable[256] = { false };

int main() {

	string a, b;
	
	getline(cin, a);
	getline(cin, b);

	int len1 = a.length();
	int len2 = b.length();

	for (int i = 0; i < len2; ++i) {
		hashTable[b[i]] = true;   //会发生隐式转换,这样就不用遍历了
	}

	for (int i = 0; i < len1; ++i) {
		if (hashTable[a[i]] == false) {
			printf("%c", a[i]);
		}
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值