PAT甲级 1051 Pop Sequence(25) (栈)

题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

输入

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

输出

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

样例输入 

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

样例输出 

YES
NO
NO
YES
NO

题意理解

给你一个栈 栈中元素不能超过m个 然后一共有n个数字 从1到n 一共k个出栈顺序 

问这个出栈顺序是否是合法的

那么我们只要模拟一下栈的出入即可 

一个元素一个元素的压入栈中 然后看是否符合出栈条件

如果能出栈 那就出栈一个元素 如果不行的话 那就继续压栈 直到能满足出栈条件

如果最后栈里面还有东西剩余并且没有遍历到最后一个元素的话

那么就是一个非法的出栈的顺序

代码 

#include<bits/stdc++.h>
using namespace std;
int n,m,k;
int main(){
    cin>>m>>n>>k;
    while(k--){
        vector<int>ve;
        stack<int>st;
        for(int i=0;i<n;i++){
           int  x;
           cin>>x;
           ve.push_back(x);
        }
        int fl=1;
        int j=0;
        for(int i=1;i<=n;i++){
            st.push(i);
            if(st.size()>m){
                fl=0;break;
            }
            while(st.size()&&st.top()==ve[j]){
                    j++;st.pop();
            }
        }
        if(st.size())fl=0;
        if(fl)puts("YES");
        else puts("NO");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值