PAT 甲级 1051 Pop Sequence (25分)

2 篇文章 0 订阅

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

这类题第一次遇见,关于模拟栈的问题,似懂非懂。目的:验证某个输出序列到底是不是栈的输入序列。

假设K个数,压入栈的顺序为1,2,..K.给出一个输出序列为a[ ] 。先把输入序列依次压入栈,每次压入数字就先判断是否超过了栈的容量,超出就Break.从输出序列第一个元素开始,设step = 1,判断a[step]与栈顶元素是否相同,若相同,栈顶元素出栈,step++。 当循环结束时,判断栈s是否为空,为空则a[ ] 是输出序列。(也可step为N+1)

#include <bits/stdc++.h>
#define maxn 1010

using namespace std;

int main()
{
    int M,N,K;
    cin>>M>>N>>K;
    int a[N+1]= {0};
    for(int i = 0; i<K; i++)
    {
        stack<int>s;
        for(int j = 1; j<=N; j++)
        {
            cin>>a[j];
        }
        int step = 1;
        for(int k = 1; k<=N; k++)
        {
            s.push(k);
            if(s.size()>M)
            {
                break;
            }
            if(s.top()==a[step])
            {
                while(!s.empty()&&s.top()==a[step])
                {
                    step++;
                    s.pop();
                }
            }
        }
        if(s.empty())
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值