PAT甲级 1053 Path of Equal Weight(30) (DFS)

题目

Given a non-empty tree with root R, and with weight Wi​ assigned to each tree node Ti​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

输入

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi​ (<1000) corresponds to the tree node Ti​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

输出

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A_{1}​,A_{2}​,⋯,A_{n}} is said to be greater than sequence {B_{1},B_{2}​,⋯,B_{m}} if there exists 1≤k<min{n,m} such that Ai​=Bi​ for i=1,⋯,k, and A_{K+1}​>B_{K+1}​.

样例输入 

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

样例输出 

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意理解

大致的题意是给你一棵树 树上每个结点有对应的编号和权值 让你输出从根结点到叶子结点的路径结点值等于给定的总和 要注意的是一定是叶子结点 不是路径当中的结点

比如 10 3 3 8这条路还没有到叶子结点 但是结点总和也是到了24但是不算在答案里面

那么我们跑DFS暴力的将所有到达叶子结点的路径全部搜索出来 如果到达叶子的同时 记录的路径和也是到达了给定值 那么就把这条路径加入到结果集中

最后结果集合也要排序 直接用greater<vector<int> > 按照vector降序排序

vector越靠前的元素最大的话就排在越前面 一样的话看下一个元素

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=1e3+10;
int n,m,sum;
int h[N],e[N],ne[N],idx;
void add(int a,int b){
    e[idx]=b;ne[idx]=h[a];h[a]=idx++;
}
int po[N];
vector< vector<int> >ans;
int cnt;
bool st[N];
void dfs(int u,int su,vector<int>&path){
     if(h[u]==-1){
         if(su==sum){
             ans.push_back(path);
             return ;
         }
     }
     for(int i=h[u];~i;i=ne[i]){
         int j=e[i];
         path.push_back(po[j]);
         dfs(j,su+po[j],path);
         path.pop_back();
     }
}
int main(){
    scanf("%d%d%d",&n,&m,&sum);
    memset(h,-1,sizeof h);
    for(int i=0;i<n;i++){
        scanf("%d",&po[i]);
    }
    while(m--){
         int root,k;
         scanf("%d%d",&root,&k);
         while(k--){
           int u;
           scanf("%d",&u);
           add(root,u);
         }
    }
    
    vector<int>path;
    path.push_back(po[0]);
    dfs(0,po[0],path);
    
    sort(ans.begin(),ans.end(),greater<vector<int> >());
    for(auto res:ans){
        for(int i=0;i<res.size();i++){
            if(i)printf(" ");
            printf("%d",res[i]);
        }
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值