PAT甲级 1004 Counting Leaves(30) (DFS)

题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

输入

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

输出

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

样例输入 

2 1
01 1 02

样例输出 

0 1

题意理解

题意十分简单,输入一个数n,表示的是树的结点的个数,输入m行,每一行首个id是父亲结点,该节点有k个孩子,输入k个孩子的id。最后输出树的每层叶子结点个数。注意此题的根节点默认为1。我们只要用邻接表把树存下来,然后DFS遍历一遍,开一个depth数组记录在该深度下一共有几个叶结点,同时维护最大深度即可。最后输出每层深度的结点的个数。因为每个结点只会被遍历一次,所以时间复杂度是O(n)的.(一开始没看懂题不知道根默认是从1开始,在所有结点中去找根节点导致一个测试点段错误)

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=110;
vector<int>tree[110];
int ans[110];
int cd[110*2],rd[110*2];
map<int,int>ma;
int max_depth=-1;
int n,m;
void dfs(int u,int depth){
    max_depth=max(max_depth,depth);
    if(!tree[u].size()){
        //叶子
        ans[depth]++;
        return ;
    }
    else {
        for(int i=0;i<tree[u].size();i++){
            dfs(tree[u][i],depth+1);
        }
    }
}
int main(){
    scanf("%d%d",&n,&m);
    int root=1;
    while(m--){
        int id,k;
        scanf("%d%d",&id,&k);
        cd[id]=k;//出度
        while(k--){
            int tid;
            scanf("%d",&tid);
            rd[tid]++;//入度
            tree[id].push_back(tid);
        }
    }
    dfs(1,0);
    for(int i=0;i<=max_depth;i++){
        if(i)printf(" ");
        printf("%d",ans[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值