PAT甲级 1063 Set Similarity(25) (STL)

题目

Given two sets of integers, the similarity of the sets is defined to be N_{c}​/N_{t}×100%, where Nc​ is the number of distinct common numbers shared by the two sets, and Nt​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^{4}) and followed by M integers in the range [0,10^{9}]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入 

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出 

50.0%
33.3%

题意理解

先输出n表示有n个集合 每个集合中的元素要去重

我们可以用set解决这个问题

然后有m个查询 输入集合 a和b 的编号

在集合中两个集合都有的公共元素个数是两个集合元素的剩余总元素和的多少百分比

那么我们直接暴力查询就好了

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=55;
set<int>st[N];
int n,m;
int main(){
    cin>>n;
    for(int i=1,k;i<=n;i++){
        scanf("%d",&k);
        for(int j=1,x;j<=k;j++){
            scanf("%d",&x);
            st[i].insert(x);
        }
    }
    cin>>m;
    for(int i=1,a,b;i<=m;i++){
        int cnt=0;
        scanf("%d%d",&a,&b);
        for(auto e:st[a]){
            if(st[b].count(e))cnt++;
        }
        printf("%0.1lf%%\n",cnt*1.0/(st[a].size()+st[b].size()-cnt)*100.0);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值