【数据结构第一周】01-复杂度2 Maximum Subsequence Sum (25 分)

01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j(as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码如下:

#include<stdio.h>
int* MaxSubsequenceSum(const int A[],int N);

int main(void){
  int N;
  int A[10000];
  int* ans;
  
  scanf("%d",&N);
  for(int i=0;i<N;i++)
    scanf("%d",&A[i]);
    
  ans=MaxSubsequenceSum(A,N);
 
  printf("%d %d %d\n",ans[0],A[ans[1]],A[ans[2]]);//因为ans[]存的是下标
  
  return 0;
}

/*函数的思路:
   1.输出三个数,因此返回值设为指针
   2.start2是中间变量。因为start有延迟,因为可能有几段序列和均大于0,
   但不一定都比最大值大,但每一次大于0的序列都需要记录start,所以就用中间变量start2来记录。
   当序列和大于最大值时,才更新start,即start=start2。
   3.end,start,start2全都对应的是数组A[]的下标*/ 

int* MaxSubsequenceSum(const int A[],int N){
  int ThisSum=0, MaxSum=0, j, start, end=N-1, start2=0;
  static int ans[3];
  int count=0;
  int flag=0;
  
  for(int i=0; i<N; i++){
    if(A[i]<0)count++;
  }
  if(count==N)//全是负数
     flag=1;

    for(j=0; j<N; j++){
    ThisSum += A[j];
    
     
    if(ThisSum > MaxSum){
      MaxSum=ThisSum;
      end=j;
      start=start2;
    }
    else if(ThisSum<0){//置0,start2指向下一个 
      ThisSum=0;
      start2=j+1;
    }
  }

  // ans[0]=MaxSum;
  // ans[1]=start;
  // ans[2]=end;

  if(MaxSum==0)
    {
        if(flag){//全是负数 
          ans[0]=MaxSum;
          ans[1]=0;
          ans[2]=N-1; 
        }
        else{//实现“负数和 0”这种情况 
          // ans[0]=MaxSum;原始想法
          // ans[1]=0;
          // ans[2]=0;
          ans[0]=MaxSum;
          ans[1]=start2;//变了
          ans[2]=start2;
        }
    }

  else{
  	ans[0]=MaxSum;
    ans[1]=start;
    ans[2]=end;
  }
  
  return ans;
}

参考:https://blog.csdn.net/weixin_41066584/article/details/79921190https://blog.csdn.net/qq_37513086/article/details/79732377

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值