hdu 4387 双连通分量 求权值最小的桥

Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3639    Accepted Submission(s): 1146


Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

Sample Input
  
  
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

Sample Output
  
  
-1 4
 

Source
 
解析:
求无向图的双连通分量的桥,若本来图就没有连通,就不派人去,若桥的权值为0,还要派1个人去。求桥用tarjan算法。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 1000000+10;
const int Maxn = 1000+10;
const int inf = 0x3f3f3f3f;
int n, m;
struct EDGE
{
    int t, c, next;
}edge[maxn];

int dfn[Maxn], low[Maxn];
vector<int>ans[10000+10];

int g[Maxn][Maxn], head[Maxn];

int cnt = 0;

void addedge(int u, int v, int c) {
    edge[cnt].t = v;
    edge[cnt].c = c;
    edge[cnt].next = head[u];
    head[u] = cnt;
    cnt++;
    edge[cnt].t = u;
    edge[cnt].c = c;
    edge[cnt].next = head[v];
    head[v] = cnt;
    cnt++;
}


int stack[Maxn], sk;
void tarjan(int now, int &sig, int &num, int from) {
    dfn[now] = low[now] = ++sig;
    for (int i=head[now]; i!=-1; i=edge[i].next) {
        if (i == (from^1))
            continue;
        if (!dfn[edge[i].t]) {
            tarjan(edge[i].t, sig, num, i);
            low[now] = min(low[now], low[edge[i].t]);
            if (low[edge[i].t] > dfn[now]) {
                ans[num].push_back(now);
                ans[num].push_back(edge[i].t);
                num++;
            }
        }
        else            
           low[now] = min(low[now], dfn[edge[i].t]);
    }
}
int vis[Maxn];
void dfs(int u, int &len) {
    vis[u] = 1;
    for (int i=head[u]; i!=-1; i=edge[i].next)
        if (!vis[edge[i].t]) 
            len++, dfs(edge[i].t, len);
}


int main()
{
    while (scanf("%d%d", &n, &m)!=EOF) {
        if (n==0 && m==0) break;
        cnt = 0;
        memset(low, 0, sizeof(low));
        memset(dfn, 0, sizeof(dfn));
        memset(g, inf, sizeof(g));;
        memset(head, -1, sizeof(head));
        for (int i=0; i<m; i++) {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            g[u][v] = w;
            g[v][u] = w;
            addedge(u, v, w);
        }
        int sig, num, res = inf;
        sig = num = 0;
        memset(vis, 0, sizeof(vis));
        int len=1;
        dfs(1, len);
        if (len < n) {
            printf("0\n");
            continue;
        }
	    tarjan(1, sig, num, -1);
        for (int i=0; i<num; i++) {
            res = min(res, g[ans[i][0]][ans[i][1]]);
        }
        for (int i=0; i<num; i++)
            ans[i].clear();

        if (res != inf && res != 0)
            printf("%d\n", res);
        else if (res == 0)
            cout << "1" << endl;
        else
            cout << "-1" << endl;
    }
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了模 n 意义下的所有原根,我们需要先出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于最大公约数,phi 函数用于欧拉函数,pow 函数用于快速幂模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值