EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12782 Accepted: 8093
Description
In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.
The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.
Note:
- It does not matter what order the buttons are pressed.
- If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
- As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.
Input
The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output
For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input
2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0
Sample Output
PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1
题解
对于一个开关,我们是没有必要按两次的,两次就相当于没按。然后我们发现当我们按下一个开关的时候,受影响的只能是上下左右和自己,我们假设初始矩阵
然后我们按下了位于 (2,2) ( 2 , 2 ) 的开关实际上就相当于初始矩阵 xor x o r 上了矩阵 ① ① <script type="math/tex" id="MathJax-Element-751">①</script>,就变成了矩阵②.
所以对于矩阵中的每一个点,我们都可以对其建立一个异或方程.最后用高斯消元求解异或方程就可以了
建立的时候注意细节
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
const int MAXN=60;
int mx[5]={0,0,0,1,-1};
int my[5]={0,1,-1,0,0};
int a[MAXN][MAXN],n,m,N;
using namespace std;
int Change(int x,int y)
{
return (x-1)*6+y;
}
void gauss()
{
int x,y;
int i=1;
for(int j=1;i<=30&&j<=30;j++)
{
for(k=i;k<=30;k++)
if(a[k][j]) break;
if(a[k][j])
{
for(l=1;l<=31;l++) swap(a[i][l],a[k][l]);
for(l=1;l<=30;l++)
{
if(l!=i&&a[l][j])
for(k=1;k<=31;k++)
a[l][k]^=a[i][k];//改为异或操作
}
i++;
}
}
}
int main()
{
n=5,m=6;
scanf("%d",&N);
for(int WW=1;WW<=N;WW++)
{
for(int i=1;i<=5;i++)
for(int j=1;j<=6;j++)
{
scanf("%d",&a[Change(i,j)][31]);
for(int k=1;k<=4;k++)
{
int x=i+mx[k],y=j+my[k];
if(x<=5&&y<=6&&x>=1&&y>=1)
{
a[Change(i,j)][Change(x,y)]=1;//只有相邻的系数才为1
}
}
}
for(int i=1;i<=30;i++) a[i][i]=1;
gauss();
printf("PUZZLE #%d\n",WW);
for(int i=1;i<=30;i++)
{
printf("%d ",a[i][31]);
if(i%6==0) printf("\n");
}
memset(a,0,sizeof(a));
}
return 0;
}