Hdu 2767 Proving Equivalences Tarjan 题解

Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?


Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3


Sample Output

4
2


显然题目大概是这么个意思
这里写图片描述

不要问我为什么变量都这么抽象,后面都多了一个字母,那是因为我以前被hdu卡过,就因为变量的原因…注意这道题special judge,如果只有一个scc,不用连边

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
const int MAXN = 100000;
using namespace std;
int readin(){
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9')ch=getchar();
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
struct Line{int from,to,nxt;}line[MAXN*2];
int headd[MAXN],tail_,dfnn[MAXN],loww[MAXN],inn[MAXN],outt[MAXN],timer,stk[MAXN],topp,cnt,sccc[MAXN],n,cnt_in,cnt_out,T,m,ff,tt;
bool instk[MAXN];
void add_line(int from,int to){
    tail_++;
    line[tail_].from=from;
    line[tail_].to=to;
    line[tail_].nxt=headd[from];
    headd[from]=tail_;
}
void tarjan(int u){
    dfnn[u]=loww[u]=++timer;
    stk[++topp]=u;
    instk[u]=true;
    for(register int i=headd[u];i;i=line[i].nxt){
        int v=line[i].to;
        if(!dfnn[v]){
            tarjan(v);
            loww[u]=min(loww[u],loww[v]);
        }else if(instk[v]) loww[u]=min(loww[u],dfnn[v]);
    }
    if(dfnn[u]==loww[u]){
        cnt++;
        sccc[u]=cnt;
        instk[u]=false;
        while(stk[topp]!=u){
            instk[stk[topp]]=false;
            sccc[stk[topp]]=cnt;
            topp--;
        } 
        topp--;
    }
}
int counting(){
    for(register int u=1;u<=n;u++){
        for(register int j=headd[u];j;j=line[j].nxt){
            int v=line[j].to;
            if(sccc[u]==sccc[v]) continue;
            outt[sccc[u]]++;
            inn[sccc[v]]++;
        }
    }
    cnt_in=0;cnt_out=0;
    for(register int i=1;i<=cnt;i++){
        if(!inn[i])cnt_in++;
        if(!outt[i])cnt_out++;
    }
    return max(cnt_in,cnt_out);
}
//int headd[MAXN],tail_,dfnn[MAXN],loww[MAXN],inn[MAXN],outt[MAXN],timer,stk[MAXN],topp,cnt,sccc[MAXN],n,cnt_in,cnt_out,T,m,ff,tt;
//bool instk[MAXN];
void init(){
    memset(headd,0,sizeof(headd));timer=0;cnt=0;topp=0;tail_=0;
    memset(inn,0,sizeof(inn));
    memset(stk,0,sizeof(stk));
    memset(outt,0,sizeof(outt));
    memset(instk,false,sizeof(instk));
    memset(dfnn,0,sizeof(dfnn)); 
    memset(sccc,0,sizeof(sccc));
}
int main(){
    //freopen(".txt","r",stdin);
    //freopen(".outt","w",stdout);
    T=readin();
    while(T--){
        init();
        n=readin();m=readin();
        for(register int i=1;i<=m;i++) scanf("%d%d",&ff,&tt),add_line(ff,tt);
        for(register int i=1;i<=n;i++) if(!dfnn[i]) tarjan(i);
        if(cnt==1) printf("0\n");
        else  printf("%d\n",counting());
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值