description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
题目大意
给你一个0到n-1的排列,计算逆序对个数,然后再把第一个数移到最后面去,计算逆序对个数,然后再移新的第一个数到最后面去,计算逆序对个数,移完一圈之后,问逆序对个数最少的一次,逆序对个数是多少?
显然这道题可以用树状数组很快地处理出来,可以直接用树状数组求逆序对,然后再通过第一个逆序对去推后面的逆序对个数,观察一下可以发现,原来的第一个数被移到最后面去了的时候,其实新的贡献就是加上前面有多少大于他的数,然后再减去之前的贡献,也就是他在第一位的时候后面有多少个数比他小,然后更新答案,进行比较
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN =50000;
int C[MAXN],a[MAXN],n,final;
int lowbit(int x){return x&(-x);}
void modify(int x,int val){
while(x<=n){
C[x]+=val;
x+=lowbit(x);
}
}
int query(int x){
int ass=0;
while(x){
ass+=C[x];
x-=lowbit(x);
}
return ass;
}
void init(){
memset(C,0,sizeof(C));
final=0;
}
int main(){
while(~scanf("%d",&n)){
init();
for(register int i=1;i<=n;i++){
scanf("%d",&a[i]);
modify(a[i]+1,1);
final+=i-query(a[i]+1);
}
int temp=final;
for(register int i=1;i<=n;i++){
temp+=(n-a[i]-1)-a[i];
final=min(final,temp);
}
printf("%d\n",final);
}
return 0;
}