HDU 1394 Minimum Inversion Number (树状数组求逆序数)


Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13942    Accepted Submission(s): 8514

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 
Output
For each case, output the minimum inversion number on a single line.
 
Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 
Sample Output
  
  
16
 
Author
CHEN, Gaoli
 
Source
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1394

题目大意:给一组数,每次可以把开头的数拿到末尾,问这样组成的序列中逆序数最小的逆序数值

题目分析:先用树状数组求逆序数,每次交换后的逆序数值可以直接算出来,因为是一个0~n-1的排列,所以把第一个数(设为fir)拿到最后先当作减少了fir个逆序数,又这组排列中肯定有n-fir-1个数是大于fir的,再把它们加上,所以逆序数变化的个数为-fir+n-fir-1


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 5005;
int c[MAX], a[MAX], n;

int lowbit(int x)
{
    return x & (-x);
}

void Add(int x)
{
    for(int i = x; i <= n; i += lowbit(i))
        c[i] ++;
}

int Sum(int x)
{
    int res = 0;
    for(int i = x; i > 0; i -= lowbit(i))
        res += c[i];
    return res;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        memset(c, 0, sizeof(c));
        int ini = 0;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            a[i] ++;
            ini += Sum(n) - Sum(a[i]);
            Add(a[i]);
        }
        int mi = ini;
        for(int i = 1; i <= n; i++)
        {
            ini += (-(a[i] - 1) + n - (a[i] - 1) - 1);
            mi = min(mi, ini);
        }
        printf("%d\n", mi);
    }
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值