PoJ 2417 Discrete Logging BSGS裸题

Description

Given a prime P, 2 <= P < 2 31, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that
B^L == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print “no solution”.

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat’s theorem that states
B(P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat’s theorem is that for any m
B(-m) == B(P-1-m) (mod P) .


就是求指数,也就是离散对数的值,直接BSGS,这次写的是map的,下次写哈希表吧

#include <cmath>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>
using namespace std;  
long long a,b,c,m;  
map<long long,int> mp;  
long long fast_pow( long long x, long long y ) {
    long long BASE = x, tmp = 1;
    while( y ) {
        if( y & 1 ) tmp = ( tmp * BASE ) % c;
        y >>= 1;
        BASE = ( BASE * BASE ) % c;
    }
    return tmp;
}
long long gcd( long long x, long long y ) { return y == 0 ? x : gcd( y, x % y ); }
int main() {
    while( scanf( "%lld%lld%lld", &c, & a, &b ) != EOF ) { //A^x=B(mod C)
        mp.clear();bool judge = false;
        if( gcd( a, c ) != 1 ) {
            printf( "no solution\n" );
            continue;
        }
        m = ceil( sqrt ( c ) );
        long long ans;
        for( register int i = 0; i <= m; i++ ) {
            if( i == 0 ){ ans = b % c; mp[ans] = i; continue; }
            ans = ( ans * a ) % c;
            mp[ans] = i;
        } 
        long long am = fast_pow( a, m ); ans = 1;
        for( register int i = 1; i <= m; i++ ) {
            ans = ( ans * am ) % c;
            if( mp[ans] ) {
                int tmp = i * m - mp[ans];
                printf( "%d\n", ( tmp % c + c ) % c );
                judge = true;
                break;
            }
        }
        if( judge == false ) printf( "no solution\n" );
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
系统根据B/S,即所谓的电脑浏览器/网络服务器方式,运用Java技术性,挑选MySQL作为后台系统。系统主要包含对客服聊天管理、字典表管理、公告信息管理、金融工具管理、金融工具收藏管理、金融工具银行卡管理、借款管理、理财产品管理、理财产品收藏管理、理财产品银行卡管理、理财银行卡信息管理、银行卡管理、存款管理、银行卡记录管理、取款管理、转账管理、用户管理、员工管理等功能模块。 文中重点介绍了银行管理的专业技术发展背景和发展状况,随后遵照软件传统式研发流程,最先挑选适用思维和语言软件开发平台,依据需求分析报告模块和设计数据库结构,再根据系统功能模块的设计制作系统功能模块图、流程表和E-R图。随后设计架构以及编写代码,并实现系统能模块。最终基本完成系统检测和功能测试。结果显示,该系统能够实现所需要的作用,工作状态没有明显缺陷。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。进入银行卡列表,管理员可以进行查看列表、模糊搜索以及相关维护等操作。用户进入系统可以查看公告和模糊搜索公告信息、也可以进行公告维护操作。理财产品管理页面,管理员可以进行查看列表、模糊搜索以及相关维护等操作。产品类型管理页面,此页面提供给管理员的功能有:新增产品类型,修改产品类型,删除产品类型。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值