任重而道远
Description
Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that
BL == N (mod P)
Input
Read several lines of input, each containing P,B,N separated by a space.
Output
For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".
Sample Input
5 2 1 5 2 2 5 2 3 5 2 4 5 3 1 5 3 2 5 3 3 5 3 4 5 4 1 5 4 2 5 4 3 5 4 4 12345701 2 1111111 1111111121 65537 1111111111
Sample Output
0 1 3 2 0 3 1 2 0 no solution no solution 1 9584351 462803587
Hint
The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states
B(P-1) == 1 (mod P)
for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m
B(-m) == B(P-1-m) (mod P)
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;
typedef long long ll;
map <ll, int> mp;
ll a, b, mod;
ll mpow (ll a, ll b) {
ll rt = 1;
for (; b; b >>= 1, a = a * a % mod)
if (b & 1) rt = rt * a % mod;
return rt;
}
int main () {
while (cin >> mod >> a >> b) {
if (a % mod == 0) {
cout << "no solution" << endl;
continue;
}
mp.clear ();
bool flag = false;
ll m = ceil (sqrt (mod));
ll cur = b % mod;
mp[cur] = 0;
for (int i = 1; i <= m; i++) {
cur = cur * a % mod;
mp[cur] = i;
}
ll t = mpow (a, m);
cur = 1;
for (int i = 1; i <= m; i++) {
cur = cur * t % mod;
if (mp[cur]) {
flag = true;
int ans = i * m - mp[cur];
cout << ans << endl;
break;
}
}
if (!flag) {
cout << "no solution" << endl;
}
}
return 0;
}
推荐博客:https://blog.csdn.net/zzkksunboy/article/details/73162229