POJ 2417 Discrete Logging

99 篇文章 0 订阅
3 篇文章 0 订阅

Description

Given a prime P, 2 <= P < 2 31, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that 
    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states 
   B(P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m 
   B(-m) == B(P-1-m) (mod P) .

Source

Waterloo Local 2002.01.26

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

BSGS~

BSGS—Baby-Step-Giant-Step,用于解方程A^x≡B(mod C):

设m=ceil(sqrt(C))(ceil即上取整),x=i*m-j,则A^(i*m)B*A^j(mod C)。

我们从0~m枚举j,将求得的B*A^j存入一个hash表中(用map替代),然后1~m枚举i,将对应的A^(i*m)与hash匹配,第一个出现再map中的即为答案。

(更详细的证明:http://blog.csdn.net/clover_hxy/article/details/50683832~)

(POJ上用C++交这题会CE,要用G++交~)


#include<cstdio>
#include<cstring>
#include<iostream>
#include<map>
#include<cmath>
using namespace std;
#define ll long long

ll a,b,c,ans,now;
int m;
bool tr;
map<ll,int> ma;

ll mi(ll u,ll v)
{
	ll num=1;
	while(v)
	{
		if(v&1) num=(num*u)%c;
		v>>=1;u=u*u%c;
	}
	return num;
}

int main()
{
	while(scanf("%d%lld%lld",&c,&a,&b)!=EOF)
	{
		ma.clear();
		if(!(a%c))
		{
			printf("no solution\n");continue;
		}
		m=sqrt(c);tr=0;
		if(c!=m*m) m++;
		ans=b%c;ma[ans]=0;
		for(int i=1;i<=m;i++)
		{
			ans=(ans*a)%c;ma[ans]=i;
		}
		ans=1;now=mi(a,m);
		for(int i=1;i<=m;i++)
		{
			ans=(ans*now)%c;
			if(ma[ans])
			{
				now=i*m-ma[ans];
				printf("%lld\n",(now%c+c)%c);
				tr=1;break;
			}
		}
		if(!tr)
		{
			printf("no solution\n");continue;
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值