1002. A+B for Polynomials (25)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
文章大意就是两个多项式相加,每行第一个数是项数,特殊情况就是相加系数为0的时候

#include <stdio.h>

struct Polynomials
{
	int Lndex;
	double Coefficient; 
};

int i;
 
void Input(int K,Polynomials Poly[]);
void Sort(int K1,Polynomials Poly1[],int K2,Polynomials Poly2[],int K,Polynomials Poly[]); 

int main()
{
	int K1,K2;
	Polynomials Poly1[11],Poly2[11],Poly[22];
	
	scanf("%d",&K1);
	Input(K1,Poly1);
	scanf("%d",&K2);
	Input(K2,Poly2); 
	
	int K=0; 
	Sort(K1,Poly1,K2,Poly2,K,Poly);
	 
	return 0; 
}

void Input(int K,Polynomials Poly[])
{
	for(i=0;i<K;i++)
	{
		scanf("%d %lf",&Poly[i].Lndex,&Poly[i].Coefficient); 
	} 
}

void Sort(int K1,Polynomials Poly1[],int K2,Polynomials Poly2[],int K,Polynomials Poly[])
{
	int j=0;
	for(i=0;i<K1&&j<K2;)
	{
		if(Poly1[i].Lndex==Poly2[j].Lndex)
		{
			if(Poly1[i].Coefficient+Poly2[j].Coefficient==0)
			{
				i++;
				j++; 
			} 
			else
			{
				Poly[K].Lndex=Poly1[i].Lndex;
				Poly[K].Coefficient=Poly1[i].Coefficient+Poly2[j].Coefficient;
				K++;
				i++;
				j++; 
			} 
		}
		else if(Poly1[i].Lndex>Poly2[j].Lndex)
		{
		    Poly[K].Lndex=Poly1[i].Lndex;
		    Poly[K].Coefficient=Poly1[i].Coefficient;
		    K++;
		    i++; 
		}
		else
		{
            Poly[K].Lndex=Poly2[j].Lndex;
		    Poly[K].Coefficient=Poly2[j].Coefficient;
		    K++;
		    j++; 
		} 
	}
	while(i<K1)
	{
        Poly[K].Lndex=Poly1[i].Lndex;
        Poly[K].Coefficient=Poly1[i].Coefficient;
        K++;
        i++; 
	} 
	while(j<K2)
	{   
	    Poly[K].Lndex=Poly2[j].Lndex;
	    Poly[K].Coefficient=Poly2[j].Coefficient;
        K++;
	    j++; 
	} 
	printf("%d",K);
	for(i=0;i<K;i++)
	{
		printf(" %d %.1lf",Poly[i].Lndex,Poly[i].Coefficient); 
	}
	printf("\n"); 
} 


#include <stdio.h> 
#include <math.h> 
#define ESP 0.05 
struct Polynomials 
{ 
    int Lndex; 
    double Coefficient;  
}; 


int i; 
  
void Input(int K,Polynomials Poly[]); 
void Add(int K1,Polynomials Poly1[],int K2,Polynomials Poly2[],int K,Polynomials Poly[]);  


int main() 
{ 
    int K1,K2; 
    Polynomials Poly1[11],Poly2[11],Poly[22]; 
     
    while(scanf("%d",&K1)!=EOF) 
    {     
        Input(K1,Poly1); 
        scanf("%d",&K2); 
        Input(K2,Poly2);  
         
        int K=0;  
        Add(K1,Poly1,K2,Poly2,K,Poly); 
    }  
    return 0;  
} 


void Input(int K,Polynomials Poly[]) 
{ 
    for(i=0;i<K;i++) 
    { 
        scanf("%d %lf",&Poly[i].Lndex,&Poly[i].Coefficient);  
    }  
} 


void Add(int K1,Polynomials Poly1[],int K2,Polynomials Poly2[],int K,Polynomials Poly[]) 
{ 
    int j=0; 
    for(i=0;i<K1&&j<K2;) 
    { 
        if(Poly1[i].Lndex==Poly2[j].Lndex) 
        { 
            if(Poly1[i].Coefficient+Poly2[j].Coefficient==0) 
            { 
                i++; 
                j++;  
            }  
            else 
            { 
                Poly[K].Lndex=Poly1[i].Lndex; 
                if(fabs(Poly1[i].Coefficient+Poly2[j].Coefficient)>=ESP) 
                { 
                   Poly[K].Coefficient=Poly1[i].Coefficient+Poly2[j].Coefficient; 
                   K++; 
                } 
                i++; 
                j++;  
            }  
        } 
        else if(Poly1[i].Lndex>Poly2[j].Lndex) 
        { 
            Poly[K].Lndex=Poly1[i].Lndex; 
            if(fabs(Poly1[i].Coefficient)>=ESP) 
            { 
                Poly[K].Coefficient=Poly1[i].Coefficient; 
                K++; 
            } 
            i++;  
        } 
        else 
        { 
            Poly[K].Lndex=Poly2[j].Lndex; 
            if(fabs(Poly2[j].Coefficient)>=ESP) 
            { 
                Poly[K].Coefficient=Poly2[j].Coefficient; 
                K++; 
            } 
            j++;  
        }  
    } 
    while(i<K1) 
    { 
        Poly[K].Lndex=Poly1[i].Lndex; 
        if(fabs(Poly1[i].Coefficient)>=ESP) 
        { 
            Poly[K].Coefficient=Poly1[i].Coefficient; 
            K++; 
        } 
        i++;  
    }  
    while(j<K2) 
    {    
        Poly[K].Lndex=Poly2[j].Lndex; 
        if(fabs(Poly2[j].Coefficient)>=ESP) 
        { 
            Poly[K].Coefficient=Poly2[j].Coefficient; 
            K++; 
        } 
        j++;  
    }  
    printf("%d",K); 
    for(i=0;i<K;i++) 
    { 
        printf(" %d %.1lf",Poly[i].Lndex,Poly[i].Coefficient);  
    } 
    printf("\n");  
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值