1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

 Input Specification: 
Each input file contains multiple test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification: 
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place. 


Sample Input

2 1 2.4 0 3.2


2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

#include <stdio.h> 
#include <math.h> 

#define MAX 2001 
#define Max 1001 
#define EPS 0.05 

double Poly1[Max]; 
double Poly2[Max]; 
double Poly3[MAX]; 

void Initial(); 
void Input(int K); 
void Mul(); 
void Output();  
  
int main() 
{ 
    int K1; 
    while(scanf("%d",&K1)!=EOF) 
    { 
        Initial(); 
        Input(K1); 
        Mul(); 
        Output(); 
    } 
    return 0; 
} 

void Initial() 
{ 
    int i; 
    for(i=0;i<Max;i++) 
    { 
        Poly1[i]=0.0;  
    } 
    for(i=0;i<Max;i++) 
    { 
        Poly2[i]=0.0;  
    } 
    for(i=0;i<MAX;i++) 
    { 
        Poly3[i]=0.0;  
    } 
} 

void Input(int K) 
{ 
    int i,j; 
    for(i=0;i<K;i++) 
    { 
        scanf("%d",&j); 
        scanf("%lf",&Poly1[j]);  
    } 
    int n,k; 
    scanf("%d",&k);     
    for(i=0;i<k;i++) 
    { 
        scanf("%d",&n); 
        scanf("%lf",&Poly2[n]);  
    } 
} 

void Mul() 
{ 
    int i,j; 
    for(i=0;i<Max;i++) 
    { 
       for(j=0;j<Max;j++) 
       { 
            Poly3[i+j]+=Poly1[i]*Poly2[j]; 
         } 
    } 
} 

void Output() 
{ 
    int i; 
    int n=0; 
    for(i=MAX;i>=0;i--) 
    { 
        if(fabs(Poly3[i])>=EPS) 
        { 
            n++;     
        } 
    } 
    printf("%d",n); 
    for(i=MAX;i>=0;i--) 
    { 
        if(fabs(Poly3[i])>=EPS) 
        { 
            printf(" %d %.1lf",i,Poly3[i]);     
        } 
    } 
    printf("\n"); 
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值