2016 Multi-University Training Contest 3-1011.Teacher Bo,暴力!

Teacher Bo

                                                        Time Limit: 4000/2000 MS (Java/Others)    

                                                   Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked  N  points in the map,the  i -th point is at  (Xi,Yi) .He wonders,whether there is a tetrad  (A,B,C,D)(A<B,C<D,ACorBD)  such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer  T . There are  T  test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the  i -th line shows the coordinate of the  i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T  lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
  
  
YES NO

  这题实在找不到什么方法做了,只能暴力试试,可是居然卡在曼哈顿路径的概念上了;

  我们以为是两点间的距离公示,然后用hypot( ,)WA了两遍,之后两小时一直像睡着了了一样;

  早知道百度一下概念,也不会耽误这么多时间,最后两分钟改了求距离那里直接交一发A了;

#include<bits/stdc++.h>
using namespace std;
const int N=100000+10;
struct node
{
    int x,y;
} a[N];
int cmp(node a,node b)
{
    if(a.x!=b.x) return a.x<b.x;
    return a.y<b.y;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        set<double>m;
        for(int i=0; i<n; i++)
            scanf("%d%d",&a[i].x,&a[i].y);
        sort(a,a+n,cmp);
        for(int i=1; i<n; i++)
        {
            if(a[i].x==a[i-1].x&&a[i].y==a[i-1].y)
            {
                for(int j=i+1; j<n; j++)
                    a[j]=a[j-1];
                n--;
                i--;
            }
        }
        int f=0;
        for(int i=0; i<n; i++)
        {
            if(f) break;
            for(int j=i+1; j<n; j++)
            {
                double dis=abs(a[i].x-a[j].x)+abs(a[i].y-a[j].y);//主要还是概念没搞清,其他地方全正确;
                if(m.find(dis)!=m.end())
                {
                    f=1;
                    break;
                }
                m.insert(dis);
            }
        }
        if(f) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
同!志!仍!需!努!力!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值