见微知著----POJ2082(堆栈)

POJ2082 Terrible Sets

Description
Let N be the set of all natural numbers {0 , 1 , 2 , … }, and R be the set of all real numbers. wi, hi for i=1,2,...,n are some elements in N, and w0=0 .
Define set B = { <x,y>|x,yR <script type="math/tex" id="MathJax-Element-1160"> |x,y∈R</script> and there exists an index i>0 such that 0yhi,0ji1wjx0jiwj }
Again, define set S = {A| A = WH for some W , H ∈ R and there exists x0, y0 in N such that the set T = { <x,y>|x,yR <script type="math/tex" id="MathJax-Element-1163"> | x, y ∈ R</script> and x0xx0+W and y0yy0+H } is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it’s difficult.
Input
The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1n50000 and w1h1+w2h2+...+wnhn<109 .
Output
Simply output Max(S) in a single line for each case.
Sample Input
3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output
12
14

问题简介:
假设紧贴着x轴的有一些互相紧贴着的矩形,给定每个矩形的长和宽,求他们可以形成的最大矩形的面积?(其中输入n相当于矩形的个数,当n=-1时输入结束。)
问题解析:
这个问题应该考虑使用堆栈来做。
若矩形的高度递增,即目标的矩形的依次高于其前面位置的矩形时,将目标矩形入栈,记录栈顶元素矩形高度为lasth;
若即将入栈的矩形高度小于lasth,则退栈直到栈顶元素高度小于目标的矩形高度,设该元素为x,在退栈过程中统计在x到lasth之间形成的最大矩形面积S,记录从x到lasth之间矩形的宽度totalw,然后将一个宽度为totalw + data.w,高度为data.h的矩形入栈,然后读入下一个矩形。
最后栈内元素必为递增 ,扫描一遍栈即可。

代码

#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;

struct rec      //建立矩形结构体
{
    int w;
    int h;
} data;
int main()
{
    int i,n,lasth,totalw,curarea,ans;
    while(scanf("%d",&n)&& n!= -1)
    {
        ans = 0;
        stack<rec>s;        //定义一个空栈
        lasth = 0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&data.w,&data.h);
            if(data.h > lasth)  //若新矩形高于最高,则入栈
            {
                s.push(data);
            }
            else
            {
                totalw = 0;
                curarea = 0;
                while(!s.empty() && s.top().h > data.h)
    //比较直到找到可以使栈内高度递增的高度
                {
                    totalw += s.top().w;
                    curarea = totalw * s.top().h;
                    if(curarea > ans)
                        ans = curarea;
                    s.pop();
                }
                totalw += data.w;
                data.w = totalw;
                s.push(data);       //压入新矩形
            }
            lasth = data.h;
        }
        totalw = 0;
        curarea = 0;
        while(!s.empty()){
            totalw += s.top().w;
            curarea = totalw * s.top().h;
            if(curarea > ans)
                ans = curarea;
            s.pop();
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值