N - John 反Nim博弈

N - John   HDU - 1907

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
 

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother

题意:约翰和他的兄弟一起玩一个游戏,游戏是这样的:在一个盒子中有若干不同颜色的糖果,约翰和他的兄弟轮流在盒子中拿出糖果,每人每次拿的糖果必须是相同颜色的,而且每次最少拿一颗,不能不拿。拿最后一颗糖果的人就输掉了这场比赛,并且要重新买一份糖果。假设两人都采用最佳的游戏策略,并且总是约翰先开始。给定盒子内糖果的信息(颜色种类、每种颜色的糖果各多少颗),问约翰和他的兄弟谁能赢得比赛。

分析:该题为反Nim博弈,即拿到最后一颗糖的人输。我们把不同颜色的糖果看成不同堆,每次在一堆中拿至少一颗糖。反Nim博弈获胜的局面有两种:1、所有堆的数目异或结果不等于0,且存在数目大于1的堆;2、异或结果等于0,且所有堆的数目全为1。满足这两个条件之一,就可赢得比赛。

代码:

//反nim博弈,先手必胜的局面有两种 
//1、异或结果不等于0,且存在石子数目大于1的石子堆 
//2、异或结果等于0,且所有石子堆的数目全为1  
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int num[50];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,flag=0;//flag判断是否存在数目大于1的石子堆  
		cin>>n;
		for(int i=1;i<=n;i++)
		{
			cin>>num[i];
			if(num[i]>1)
				flag=1;
		}
		int tmp=0;
		for(int i=1;i<=n;i++)
			tmp=tmp^num[i];
		if(tmp!=0)
		{
			if(flag==1)//异或结果不为0,且存在数目大于1的堆  
				printf("John\n");
			else
				printf("Brother\n");
		}
		else
		{
			if(flag==0)//异或结果等于0,且所有堆的数目都等于1  
				printf("John\n");
			else
				printf("Brother\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值