Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.
Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.
Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
Sample Input
2 3 3 5 1 1 1
Sample Output
John Brother
题意:
有n堆石子,每堆石子的个数已知,两个人轮流从某个石堆取石子,至少去取一个,最多将该堆石子取完。谁取完最后一个石子谁输。
问先手比赢还是后手比赢?
分析:
明显的Anti_SG游戏,而且模型还是使用的nim游戏模型,根据SJ定理可以得到将所有石堆的sg值异或起来为ans,所有石堆的sg值中大于1的石堆个数为cnt.
先手比赢当且仅当 ans != 0 && cnt > 0 || ans == 0 && cnt == 0
如果对Anti_SG游戏或者SJ定理不了解的请看这里 : 虚位以待。
代码:
#include<stdio.h>
#include<string.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,step,ans,flag;
flag = 0;ans = 0;
scanf("%d",&n);
for(int i = 0 ; i < n ; i ++)
{
scanf("%d",&step);
if(step > 1) flag ++;
ans ^= step;
}
if(ans == 0 && flag == 0 || ans != 0 && flag != 0)
printf("John\n");
else
printf("Brother\n");
}
return 0;
}