John(博弈)

Description

Little John is playing very funny game with his  younger brother. There  is one big box filled 
with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his 
opponent has to make a turn. And so on. Please no te that each player has to eat at least one 
M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be 
considered as a looser and he will have to buy a new candy box. 
Both of players are using optimal game strategy. John starts first always. You will be given 
information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next  T pairs of 
lines will describe tests in a following format. The first line of each test will contain an integer  N  – 
the amount of different M&M colors in a box. Next line will contain  N  integers Ai, separated by 
spaces – amount of M&Ms of i-th color.

Output

Output T lines each of them containing information about game winner. Print “John” if John 
will win the game or “Brother” in other case. 
Constrains: 
1 <= T <= 474, 
1 <= N <= 47, 
1 <= Ai <= 4747

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother

分析:博弈题,最后拿者输!

代码:

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int main()
{
    //freopen("a.in","r",stdin);
    //freopen("aa.out","w",stdout);
    int t,n,i,in,cnt,ans;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d",&n);
            cnt=0;ans=0;
            for(i=0;i<n;i++)
            {
                scanf("%d",&in);
                if(in==1)
                    cnt++;
                ans^=in;
            }
            if(cnt==n)
            {
                printf("%s\n",(cnt%2!=1)?"John":"Brother");
                continue;
            }
            if(ans!=0)
                printf("John\n");
            else
                printf("Brother\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值