Cube Stacking POJ - 1988 并查集

题目

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题意

有一堆箱子,初始时每个箱子自成一列,然后进行q次操作,M x y表示将x箱子所在的列搬到y所在列的上面,C x表示询问x箱子下面有几个箱子。

分析

pre[x]表示x的根节点,son[x]表示x的子树的大小,vis[x]表示x到根节点的距离,那么x下面的箱子数就等于son[find(x)]-vis[x]-1。

代码

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
const int N=3e4+5;
int pre[N],son[N],vis[N];//根节点、子树大小、到根节点的距离 
void init()
{
	memset(vis,0,sizeof(vis));
	for(int i=0;i<N;i++)
	{
		pre[i]=i;
		son[i]=1;
	}
}
int find(int x)
{
	if(x==pre[x])
		return x;
	int tmp=pre[x];
	pre[x]=find(pre[x]);
	//还没改变时,x到根节点的距离等于x到tmp的距离加上tmp到根节点的距离 
	vis[x]+=vis[tmp];
	return pre[x];
}
void unionn(int x,int y)
{
	int px=find(x);
	int py=find(y);
	if(px!=py)
	{
		pre[py]=px;
		vis[py]=son[px];//py到px的距离 
		son[px]+=son[py];//px的子树大小更新为加上py子树的大小 
	}
}
int main()
{
	int q;
	char c[2];
	scanf("%d",&q);
	init();
	while(q--)
	{
		scanf("%s",c);
		if(c[0]=='M')
		{
			int x,y;
			scanf("%d%d",&x,&y);
			unionn(x,y);
		}
		else if(c[0]=='C')
		{
			int x;
			scanf("%d",&x);
			//x根节点的子树大小,减去x到根节点的距离,再减1
			printf("%d\n",son[find(x)]-vis[x]-1); 
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值