A + B Problem II HDU - 1002(大数加法)

题目链接:点击打开链接

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 388064    Accepted Submission(s): 75108


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
 
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
大数a+b,两次比赛都没有做出来,老是出错,昨晚一直PE,无奈,竟然找不出来哪错了,,,最后一次,以后再也不能错了!!!

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[1005],b[1005];
int c[1005],d[1005],e[1005];
int main()
{
    int t,kk=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        memset(e,0,sizeof(e));
        scanf("%s%s",a,b);
        int la=strlen(a),lb=strlen(b),k=0;
        for(int i=la-1;i>=0;i--)
            c[k++]=a[i]-'0';
        k=0;
        for(int i=lb-1;i>=0;i--)
            d[k++]=b[i]-'0';
        int le=max(la,lb);
        for(int i=0;i<le;i++)
        {
            if(c[i]+d[i]+e[i]>9)
                e[i+1]++;
            e[i]=(c[i]+d[i]+e[i])%10;
        }
        printf("Case %d:\n",kk++);
        printf("%s",a);
        printf(" + ");
        printf("%s",b);
        printf(" = ");
        if(e[le])
            printf("%d",e[le]);
        for(int i=le-1;i>=0;i--)
            printf("%d",e[i]);
            printf("\n");
        if(t)
            printf("\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值