HDU 1002 A + B Problem II(大数加法)

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 426436 Accepted Submission(s): 82818

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1004 1003 1008 1005 1093

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char num[2][1001];
    int a[2][1001];
    int cnt[2];
    int sum[1005];
    int t;
    int k=0;
    scanf("%d",&t);
    while(t--)
    {
        k++;
        memset(num,0,sizeof(num));
        memset(a,0,sizeof(a));
        for(int i=0;i<2;i++)//将字符转换为数字并倒叙放入数组
        {
            scanf("%s",num[i]);
            int len=strlen(num[i]);
            cnt[i]=0;
            for(int j=len-1;j>=0;j--)
                a[i][cnt[i]++]=num[i][j]-'0';
        }
        memset(sum,0,sizeof(sum));
        for(int i=0;i<2;i++)//计算
        {
            for(int j=0;j<cnt[i];j++)
            {
                sum[j]+=a[i][j];
                if(sum[j]>=10)//两个小于10的数相加不大于20
                {
                    sum[j]=sum[j]-10;
                    sum[j+1]++;
                }
            }
        }
        int i;
        for( i=1000;i>0;i--)//结果输出
            if(sum[i])
            break;
        if(k!=1) ///注意格式输出
            printf("\n");
        printf("Case %d:\n",k);
        printf("%s + %s = ",num[0],num[1]);///空格
        for(int j=i;j>=0;j--)
            printf("%d",sum[j]);
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值