Assign the task hdu 3974(dfs序+线段树 区间更新,单点查询)

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
Sample Input
1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3
Sample Output
Case #1:
-1 
1 
2
题意:公司有n个员工,每个员工有一个上司,除非这个人是公司总领导,这n个人组成了一棵树,现在公司给员工x分配y个任务,并且员工x的下属的任务都变成了这y个任务,每当员工收到任务时,他将丢弃之前的任务,开始新的任务,现在又两种操作,一种是询问员工x当前的任务数量,一种是分配任务,如前所说。对于每次询问输出员工x当前任务数量。

思路:首先这n个员工构成了一棵树形结构,并且每次给员工分配任务时,他的子节点都变成该节点的任务数,那么当我们更新操作就是区间更新了,而查询操作是询问这个节点的任务数量,那就是单点查询了。既然存在区间操作,那么我们就要把树形结构处理成线性的区间结构,这里就要用到dfs操作了。详细看代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<stack>
using namespace std;
#define inf 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long LL;
const int mod=1e9+7;
const double pi=acos(-1);
const double eps=1e-8;
const int N=5e4+10;
bool vis[N];
int lazy[N<<2],sum[N<<2],head[N],tot,cnt,st[N],en[N];
struct node
{
    int v,net;
}e[N];
void add(int a,int b)
{
    e[tot].v=b;
    e[tot].net=head[a];
    head[a]=tot++;
}
void dfs(int u)
{
    cnt++;
    st[u]=cnt;
    for(int i=head[u];i!=-1;i=e[i].net)
        dfs(e[i].v);
    en[u]=cnt;
}
void pushdown(int rt)
{
    if(lazy[rt])
    {
        lazy[rt<<1]=lazy[rt];
        lazy[rt<<1|1]=lazy[rt];
        sum[rt<<1]=lazy[rt];
        sum[rt<<1|1]=lazy[rt];
        lazy[rt]=0;
    }
}
void build(int l,int r,int rt)
{
    lazy[rt]=0;
    sum[rt]=-1;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        lazy[rt]=c;
        sum[rt]=c;
        return ;
    }
    int m=(l+r)>>1;
    pushdown(rt);
    if(L<=m) update(L,R,c,lson);
    if(R>m) update(L,R,c,rson);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
        return sum[rt];
    int ans=0;
    int m=(l+r)>>1;
    pushdown(rt);
    if(L<=m) ans+=query(L,R,lson);
    if(R>m) ans+=query(L,R,rson);
    return ans;
}
int main()
{
    char s[2];
    int t,k=1,m,n,u,v;
    scanf("%d",&t);
    while(t--)
    {
        cnt=tot=0;
        memset(head,-1,sizeof(head));
        memset(vis,false,sizeof(vis));
        scanf("%d",&n);
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            add(v,u);//加边,注意参数顺序
            vis[u]=true;
        }
        for(int i=1;i<=n;i++)
            if(!vis[i])//找到根节点进行遍历
            {
                dfs(i);
                break;
            }
        build(1,n,1);
        scanf("%d",&m);
        printf("Case #%d:\n",k++);
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='C')
            {
                scanf("%d",&u);
                printf("%d\n",query(st[u],st[u],1,n,1));//单点查询
            }
            else
            {
                scanf("%d%d",&u,&v);
                update(st[u],en[u],v,1,n,1);//区间更新
            }
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值