【PAT甲级 - C++题解】1001 A+B Format

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1001 A+B Format (pintia.cn)
🔑中文翻译:A + B 格式
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

思路

  1. 先将 a+b 的结果转换成字符串,方便处理,这里用到的库函数是 to_string(sum) ,它可以将数字 sum 转换成字符串。
  2. 在得到的字符串 x 中,从后往前进行遍历,每次遍历都将 x[i] 加入到答案字符串数组 res 中。注意是 res = x[i] + res ,因为是从后往前遍历,所以每次加入的数字要放在 res 左边。
  3. 通过对 j 取余来判断当前是否已经遍历了 3 个数字,除此之外还要注意遍历到第一个数字的情况,如果已经遍历到第一个数字,即使已经遍历了 3 个数字也不能加逗号。

代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int a, b;
    cin >> a >> b;
    
    //进行字符串转化
    string x = to_string(a + b);
    
    //从后往前遍历
    string res = "";
    for (int i = x.size() - 1, j = 0; i >= 0; i--)
    {
        j++;
        res = x[i] + res;
        //每遍历三个数字加一个逗号,但是要排除作为第一个数字的情况
        if (j % 3 == 0 && i && x[i - 1] != '-')  res = "," + res;
    }
    cout << res << endl;
    
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值