【PAT甲级 - C++题解】1006 Sign In and Sign Out

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1006 Sign In and Sign Out (pintia.cn)
🔑中文翻译:签到与签出
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

思路

  1. 我们可以用四个变量分别记录最早来的人的 idtime 以及最晚走的人的 idtime ,在输入的过程中进行更新。
  2. 每次输入一个人的信息,都与 open_timeclose_time 进行比较,如果有更早的或者更晚的就进行更新。注意,第一个人要直接更新,因为它之前没有人所以无法进行比较。

代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
    //存储开门即最早和关门即最晚的信息,
    string open_id, open_time;
    string close_id, close_time;

    //输入有多少人
    int m;
    cin >> m;

    for (int i = 0; i < m; i++)
    {
        string id, in_time, out_time;
        cin >> id >> in_time >> out_time;

        //判断是否是来的最早的人
        if (!i || in_time < open_time)
        {
            open_id = id;
            open_time = in_time;
        }

        //判断是否是走的最晚的人
        if (!i || out_time > close_time)
        {
            close_id = id;
            close_time = out_time;
        }
    }

    cout << open_id << " " << close_id << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值