【PAT甲级 - C++题解】1016 Phone Bills

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1016 Phone Bills (pintia.cn)
🔑中文翻译:电话账单
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
思路
  1. 我们可以用一个 m a p map map 来存储所有人的所有账单, m a p map map 会自动对人名进行排序,这样就满足字典序从小到大输出每个人的要求。
  2. 输入信息时,我们可以利用 s c a n f scanf scanf 函数的性质,按照规定格式进行输入。同时,我们可以利用 s p r i n t f sprintf sprintf 函数,再存储一份格式化时间,方便后续的打印操作。
  3. 记录账单时间时,我们可以将时间用分钟来表示,由于一组数据的所有时间都会在一个月内,所以最多会有 31 31 31 天即 1440 × 31 1440×31 1440×31 分钟。这样转换,方便后续前缀和的计算。
  4. 可以用一个 s u m sum sum 数组来计算前缀和,用来存储一个月中每分钟所花费的钱,这样当计算一段区间时间时,直接用后面那段时间的 s u m [ b . m i n u t e ] sum[b.minute] sum[b.minute] 减去前面那段时间的 s u m [ a . m i n u t e ] sum[a.minute] sum[a.minute] 就是所花费的美元。注意, s u m sum sum 中已经将分钟转换成对应的美元,需要计算对应的时间以及除以 100 100 100 将美分转换成美元。
  5. 在输出时,只用从小到大遍历 m a p map map 中的元素即可,由于每个人的账单的时间输入时可能是不按顺序的,所以需要先进行排序,然后从前往后进行配对,只有遇到相邻 o n _ l i n e on\_line on_line o f f _ l i n e off\_line off_line 时才算成功配对,否则其它的账单都要忽略。
代码
#include<bits/stdc++.h>
using namespace std;

const int M = 31 * 1440 + 10;
int cost[24];
double sum[M];
int n;

//存储每一个账单
struct Record {
    int minutes;	//计算该账单的时间
    string state;	//记录该账单的状态
    string format_time;	//记录标准时间,方便输出
    bool operator <(const Record& t)const {
        return minutes < t.minutes;
    }
};

map<string, vector<Record>> persons;	//存储每一个人的所有账单

int main()
{
    for (int i = 0; i < 24; i++)   cin >> cost[i];
    //计算前缀和,将一个月中的每分钟都预处理出来
    for (int i = 1; i < M; i++)   sum[i] = sum[i - 1] + cost[(i - 1) % 1440 / 60] / 100.0;

    //输入信息,将电话账单存入对应人物的map中
    cin >> n;
    char name[25], state[10], format_time[20];
    int month, day, hour, minute;
    for (int i = 0; i < n; i++)
    {
        scanf("%s %d:%d:%d:%d %s", name, &month, &day, &hour, &minute, state);
        sprintf(format_time, "%02d:%02d:%02d", day, hour, minute);
        int minutes = (day - 1) * 1440 + hour * 60 + minute;
        persons[name].push_back({ minutes,state,format_time });
    }

    for (auto person : persons)
    {
        auto name = person.first;
        auto records = person.second;
        sort(records.begin(), records.end());

        double total = 0;
        for (int i = 0; i + 1 < records.size(); i++)
        {
            auto a = records[i], b = records[i + 1];
            if (a.state == "on-line" && b.state == "off-line")
            {
                if (!total)  printf("%s %02d\n", name.c_str(), month);
                cout << a.format_time << " " << b.format_time;
                double c = sum[b.minutes] - sum[a.minutes];
                printf(" %d $%.2lf\n", b.minutes - a.minutes, c);
                total += c;
            }
        }

        if (total)   printf("Total amount: $%.2lf\n", total);
    }
    return 0;
}
  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值