【PAT甲级】1017 Queueing at Bank

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1017 Queueing at Bank (pintia.cn)
🔑中文翻译:银行排队
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1017 Queueing at Bank

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2
思路
  1. 先用结构体数组 p e r s o n s persons persons 将所有客户到达以及服务时间记录起来,为了方便后续判断,我们统一将给定的时间转换成秒来存储。
  2. 初始化所有窗口,用小根堆来维护所有窗口的开始时间。我们可以直接用 S T L STL STL 中的优先队列 p r i o r i t y _ q u e u e priority\_queue priority_queue ,其 t o p top top 元素就是最小值。注意,由于银行是 8 8 8 点上班,所以初始化时存进去的秒是 8 ∗ 3600 8*3600 83600
  3. 对结构体数组 p e r s o n s persons persons 进行排序,以客户的到达时间为标准从小到大进行排序。
  4. 遍历排完序的结构体数组,每次遍历都从小根堆中寻找一个开始时间最早的窗口,然后更新等待时间。如果当前客户的到达时间已经大于下班时间,则直接 b r e a k break break 。注意,如果只要客户到达时间在 17 17 17 点之前,那么即使过了 17 17 17 点也能被服务。
  5. 输出平均等待时间,注意这里输出的是分钟,而我们记录的是秒数,所以求完平均后还要除以 60 60 60 转换成分钟输出。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int n, m;
struct person {
    int arrive_time;
    int service_time;
    bool operator <(const person& p)const
    {
        return arrive_time < p.arrive_time;
    }
}persons[N];

//小根堆,快速找到下一个最早能用的窗口
priority_queue<int, vector<int>, greater<int>> windows;

int main()
{
    cin >> n >> m;
    for (int i = 0; i < n; i++)
    {
        int hour, minute, second, service_time;
        scanf("%d:%d:%d %d", &hour, &minute, &second, &service_time);
        service_time = min(service_time, 60);  //服务时间不能大于60min
        persons[i] = { hour * 3600 + minute * 60 + second,service_time * 60 }; 
    }

    for (int i = 0; i < m; i++)    windows.push(8 * 3600);

    sort(persons, persons + n);

    int sum = 0, cnt = 0;
    for (int i = 0; i < n; i++)
    {
        auto person = persons[i];
        auto w = windows.top();
        windows.pop();
        if (person.arrive_time > 17 * 3600)   break;  //如果来晚了,后面的人都忽略
        int start_time = max(w, person.arrive_time); //该窗口最早开始时间  
        sum += start_time - person.arrive_time; //更新等待时间
        cnt++;
        windows.push(start_time + person.service_time);
    }

    printf("%.1f\n", (double)sum / cnt / 60);

    return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值