【PAT A1043】 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

思路:根据插入序列建立二叉排序树,再求出二叉排序树的先序序列、后序序列,二叉排序树镜像树的先序序列、后序序列。通过比较然后输出。出自《算法笔记》

#include <cstdio>
#include <vector>
using namespace std;

vector<int> origin, pre, preM, post, postM;

typedef struct BiNode {
    int data;
    struct BiNode *lchild, *rchild;
} BiNode, *BiTree;

void insert(BiTree &root, int data) {
    if (root == nullptr) { //到达空结点时,即为需要插入的位置
        root = new BiNode;
        root->data = data;
        root->lchild = root->rchild = nullptr;
        return;
    }
    if (data < root->data) {
        insert(root->lchild, data);
    } else {
        insert(root->rchild, data);
    }
}

void preOrder(BiTree root, vector<int> &vi) { //先序遍历
    if (root == nullptr) return;
    vi.push_back(root->data);
    preOrder(root->lchild, vi);
    preOrder(root->rchild, vi);
}

void preOrderMirror(BiTree root, vector<int> &vi) { //镜像树先序遍历
    if (root == nullptr) return;
    vi.push_back(root->data);
    preOrderMirror(root->rchild, vi);
    preOrderMirror(root->lchild, vi);
}

void postOrder(BiTree root, vector<int> &vi) { //后序遍历
    if (root == nullptr) return;
    postOrder(root->lchild, vi);
    postOrder(root->rchild, vi);
    vi.push_back(root->data);
}

void postOrderMirror(BiTree root, vector<int> &vi) { //镜像树后序遍历
    if (root == nullptr) return;
    postOrderMirror(root->rchild, vi);
    postOrderMirror(root->lchild, vi);
    vi.push_back(root->data);
}

int main() {
    int n, data;
    BiNode *root = nullptr;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &data);
        origin.push_back(data); //得到原始序列
        insert(root, data);
    }
    preOrder(root, pre);
    preOrderMirror(root, preM);
    postOrder(root, post);
    postOrderMirror(root, postM);
    if (origin == pre) { //插入序列是先序序列
        printf("YES\n");
        for (int i = 0; i < post.size(); i++) {
            printf("%d", post[i]);
            if (i < post.size() - 1) printf(" ");
        }
    } else if (origin == preM) { //插入序列是镜像树的先序序列
        printf("YES\n");
        for (int i = 0; i < postM.size(); i++) {
            printf("%d", postM[i]);
            if (i < postM.size() - 1) printf(" ");
        }
    } else {
        printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值