【PAT甲级 - C++题解】1155 Heap Paths

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1155 Heap Paths (pintia.cn)
🔑中文翻译:堆路径
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1155 Heap Paths

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题意

在计算机科学中,堆是一种的基于树的专用数据结构,它具有堆属性:

如果 PC 的父结点,则在大顶堆中 P 结点的权值大于或等于 C 结点的权值,在小顶堆中 P 结点的权值小于或等于 C 结点的权值。

一种堆的常见实现是二叉堆,它是由完全二叉树来实现的。

可以肯定的是,在大顶/小顶堆中,任何从根到叶子的路径都必须按非递增/非递减顺序排列。

你的任务是检查给定完全二叉树中的每个路径并输出它们,以判断它是否是堆。

思路
  1. 我们可以通过递归的方式去输出路径,每查找到一条路径就输出它。
  2. 在输出路径的时候,去判断该序列是递增还是递减还是非顺序,用两个变量去记录,一个是 lt 表示该堆是小根堆即如果该序列是递增的就标记 lt = true ,另一个是 gt 表示该堆是大根堆即如果该序列是递减的就标记 gt = true
  3. 遍历完所有路径后,判断 ltgt ,如果两个变量都是真值,说明该树不是堆(只有满足大根堆或小根堆性质的完全二叉树才能被称为堆),否则输出对应的判断结果。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 1010;
int n;
int h[N];
vector<int> path;
bool lt, gt;

void dfs(int u)
{
    path.push_back(h[u]);

    if (u * 2 > n)   //如果已经到达叶子结点
    {
        cout << path[0];
        for (int i = 1; i < path.size(); i++)
        {
            cout << " " << path[i];
            //判断该树是大根堆还是小根堆
            if (path[i] > path[i - 1])   lt = true;
            else if (path[i] < path[i - 1])  gt = true;
        }
        cout << endl;
    }

    //先递归右子树,再递归左子树
    if (u * 2 + 1 <= n)   dfs(u * 2 + 1);
    if (u * 2 <= n)   dfs(u * 2);

    path.pop_back();
}

int main()
{
    cin >> n;
    for (int i = 1; i <= n; i++)   cin >> h[i];

    dfs(1);

    if (gt && lt)  puts("Not Heap");
    else if (gt) puts("Max Heap");
    else    puts("Min Heap");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值