【PAT甲级】1150 Travelling Salesman Problem

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1150 Travelling Salesman Problem (pintia.cn)
🔑中文翻译:旅行商问题
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1150 Travelling Salesman Problem

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1 C2 … Cn

where n is the number of cities in the list, and C**i’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8
题意

“旅行商问题”是这样一个问题:“给出一个城市列表以及每对城市之间的距离,访问每个城市并返回原城市的最短路线是什么?”

在此问题中,请你从给定的路径列表中找到最接近旅行商问题的解的路径。

对于每个路径,在一行中输出 Path X: TotalDist (Description)

其中 X 是路径编号(从 1 开始),TotalDist 表示路径总距离(如果距离不存在,则输出 NA),Description 是下列中的一项:

  • TS simple cycle,如果这是一个访问每个城市的简单回路。
  • TS cycle,如果这是一个访问每个城市的回路,但不是简单回路。
  • Not a TS cycle,如果这不是一个访问了每个城市的回路。

最后一行,输出 Shortest Dist(X) = TotalDistX 是最接近旅行商问题解决方案的回路编号,TotalDist 是其总距离。

保证有唯一解。

思路

这道题满足 TS 回路的条件如下:

  1. 给定的路径是连通的路径,即需要判断路径中每条边是否存在。
  2. 每个城市是否都旅行到,即需要判断给定的路径中的城市是否能够覆盖所有 n 个城市。
  3. 给定的路径最终是否能回到源点,即需要判断给定的路径首尾城市是否相同。

另外,还需要去判断是否为简单 TS 路径,如果每个城市刚好只路过了一次,则是简单 TS 路径。

还需要注意的是,最后一行输出的最短路径是从所有 TS 路径中查找,其中包括了简单 TS 路径以及不是简单的 TS 路径。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 310, INF = 0x3f3f3f3f;
int d[N][N], vers[N];
bool st[N];
int n, m;

int main()
{
    cin >> n >> m;

    //输入无向边的信息
    memset(d, 0x3f, sizeof d);    //初始化
    for (int i = 0; i < m; i++)
    {
        int a, b, w;
        cin >> a >> b >> w;
        d[a][b] = d[b][a] = w;
    }

    //开始查询每条路径
    int k, res = INF, min_id = 0;
    cin >> k;
    for (int t = 1; t <= k; t++)
    {
        int cnt;
        cin >> cnt;
        memset(st, 0, sizeof st); //初始化
        for (int i = 0; i < cnt; i++)  cin >> vers[i];

        bool success = true;
        int sum = 0;
        for (int i = 0; i < cnt - 1; i++)    //先判断给定路径是否能连通
        {
            int a = vers[i], b = vers[i + 1];
            if (d[a][b] == INF)
            {
                sum = -1;
                success = false;
                break;
            }
            else    sum += d[a][b];   //计算路径长度
            st[a] = true; //标记路径城市
        }

        //判断是否每个城市都经过了
        for (int i = 1; i <= n; i++)
            if (!st[i])
            {
                success = false;
                break;
            }

        //判断给定路径是否能回到源点
        if (vers[0] != vers[cnt - 1])    success = false;

        //判断是否是连通的路径
        if (sum == -1) printf("Path %d: NA (Not a TS cycle)\n", t);
        else
        {
            //判断是否为TS回路
            if (!success)    printf("Path %d: %d (Not a TS cycle)\n", t, sum);
            else
            {
                //判断是否为简单TS回路
                if (cnt == n + 1)    printf("Path %d: %d (TS simple cycle)\n", t, sum);
                else    printf("Path %d: %d (TS cycle)\n", t, sum);

                //找到最短的TS回路
                if (sum < res)
                {
                    res = sum;
                    min_id = t;
                }
            }
        }
    }

    //输出最短TS回路
    printf("Shortest Dist(%d) = %d\n", min_id, res);

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值